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Working with the Timeline

The Timeline organizes and controls a documentʼs content over time in layers and frames. Like 
films, Flash documents divide lengths of time into frames. Layers are like multiple film strips 
stacked on top of one another, each containing a different image that appears on the Stage. The 
major components of the Timeline are layers, frames, and the playhead.

Layers in a document are listed in a column on the left side of the Timeline. Frames contained in 
each layer appear in a row to the right of the layer name. The Timeline header at the top of the 
Timeline indicates frame numbers. The playhead indicates the current frame displayed on the 
Stage.

The Timeline status display at the bottom of the Timeline indicates the selected frame number, 
the current frame rate, and the elapsed time to the current frame.

Note: When an animation is played, the actual frame rate is displayed; this may differ from the 
document frame rate if the computer canʼt display the animation quickly enough.

Controls in the layers section of the Timeline let you hide, show, lock, or unlock layers, as well as 
display layer contents as outlines.

To rename a layer or folder:

    - Double-click the name of a layer or folder and enter a new name.

To lock or unlock one or more layers or folders:

- Click in the Lock column to the right of the name of a layer or folder to lock it. Click in 
the Lock column again to unlock the layer or folder.
- Click the padlock icon to lock all layers and folders. Click it again to unlock all layers and 
folders.

To copy a layer:

   1. Click the layer name to select the entire layer.
   2. Select Edit > Timeline > Copy Frames.



   3. Click the Insert Layer button to create a new layer.
   4. Click the new layer and select Edit > Timeline > Paste Frames.

You can insert, delete, select, and move frames in the Timeline. You can also drag frames to a new 
location on the same layer or to a diff erent layer. See Working with frames in the Timeline.

To insert frames in the Timeline:

    - To insert a new frame, select Insert > Timeline > Frame / Keyframe / Blank Keyframe.

To select one or more frames in the Timeline:

- To select multiple contiguous frames, Shift-click additional frames.
- To select multiple discontiguous frames, Control-click (Windows) or Command-click 
(Macintosh) additional frames.

To lengthen or shorten layer name fi elds:

- Drag the bar separating the layer names and the frames portions of the Timeline.

Moving the playhead

The playhead moves through the Timeline to indicate the current frame displayed on the Stage. 
The Timeline header shows the frame numbers of the animation. To display a frame on the Stage, 
you move the playhead to the frame in the Timeline.

When youʼre working with a large number of frames that canʼt all appear in the Timeline at once, 
you can move the playhead along the Timeline to easily locate the current frame.

To go to a frame:

- Click the frameʼs location in the Timeline header, or drag the playhead to the desired po-
sition.

To center the Timeline on the current frame:

- Click the Center Frame button at the bottom of the Timeline.

Frames and keyframes

A keyframe is a frame in which you defi ne a change in an animation or include frame actions to 
modify a document. Flash can tween, or fi ll in, the frames between keyframes to produce fl uid 
animations. Because keyframes let you produce animation without drawing each frame, they make 
creating animation easier. You can change the length of a tweened animation by dragging a key-
frame in the Timeline.

To center the Timeline on the current frame:



The order in which frames and keyframes appear in the Timeline determines the order in which 
they are displayed in a Flash application. You can arrange keyframes in the Timeline to edit the 
sequence of events in an animation.

Working with layers

Layers are like transparent sheets of acetate stacked on top of each other. Layers help you orga-
nize the artwork in your document. You can draw and edit objects on one layer without affecting 
objects on another layer. Where there is nothing on a layer, you can see through it to the layers 
below.

To draw, paint, or otherwise modify a layer or folder, you select the layer to make it active. A pen-
cil icon next to a layer or folder name indicates that the layer or folder is active. Only one layer can 
be active at a time (although more than one layer can be selected at a time).

When you create a new Flash document, it contains one layer. You can add more layers to orga-
nize the artwork, animation, and other elements in your document. The number of layers you can 
create is limited only by your computerʼs memory, and layers do not increase the file size of your 
published SWF file. You can hide, lock, or rearrange layers.

You can also organize and manage layers by creating layer folders and placing layers in them. You 
can expand or collapse layers in the Timeline without affecting what you see on the Stage. Itʼs a 
good idea to use separate layers or folders for sound files, actions, frame labels, and frame com-
ments. This helps you find these items quickly when you need to edit them.

To create a layer:

- Click the Insert Layer        button at the bottom of the Timeline.

To create a layer folder:

- Click the Insert Folder        button at the bottom of the Timeline.

To move a layer or layer folder into a layer folder:

- Drag the layer or layer folder name to the destination layer folder name.

To change the order of layers or folders:

- Drag one or more layers or folders in the Timeline to the desired position.

To expand or collapse a folder:

- Click the triangle to the left of the folder name.

About the Property inspector

The Property inspector simplifies document creation by making it easy to access the most com-
monly used attributes of the current selection, either on the Stage or in the Timeline. You can 
make changes to the object or document attributes in the Property inspector without accessing 
the menus or panels that contain these features.



About the Library panel

The Library panel is where you store and organize symbols created in Flash, as well as imported 
files, including bitmap graphics, sound files, and video clips. The Library panel lets you organize 
library items in folders, see how often an item is used in a document, and sort items by type.

Depending on what is currently selected, the Property inspector displays information and settings 
for the current document, text, symbol, shape, bitmap, video, group, frame, or tool. When two or 
more different types of objects are selected, the Property inspector displays the total number of 
objects selected.

Components in the Library panel

When you add a component to a document, it is displayed as a compiled clip (SWC file) symbol in 
the Library panel.

A ComboBox component in the Library panel.

You can add more instances of a component by dragging the component icon from the library to 
the Stage. 

Working with common libraries

You can use the sample common libraries included with Flash to add buttons or sounds to your 
documents. You can also create your own common libraries, which you can then use with any 
documents that you create.

To use an item from a common library in a document:

1. Select Window > Other Panels > Common Libraries, and select a library from the sub-
menu.
2. Drag an item from the common library into the library for the current document.



To create a common library for your Flash application:

1. Create a Flash file with a library containing the symbols that you want to include in the 
permanent library.
2. Place the Flash file in the Libraries folder located in the Flash application folder on your 
hard disk.

Draw vector art

When you draw in Flash, you create vector art, which is a mathematical representation of 
lines, curves, color, and position. Vector art is resolution-independent; you can rescale the 
art to any size or display it at any resolution without losing clarity. Additionally, vector art 
downloads faster than comparable bitmap images. 

Drawing straight lines, ovals, and rectangles

You can use the Line, Oval, and Rectangle tools to easily create these basic geometric shapes. 
The Oval and Rectangle tools create stroked and filled shapes. The Rectangle tool lets you cre-
ate rectangles with square or rounded corners.

To draw a straight line, oval, or rectangle:

1. Select the Line, Oval, or Rectangle tool. 
2. Select Window > Properties and select stroke and fill attributes in the Property inspector.

Note: You cannot set fill attributes for the Line tool. 

- Rectangle tool: specify rounded corners by clicking the Round Rectangle modifier and enter-
ing a corner radius value. A value of zero creates square corners. 

Drag on the Stage. If you are using the Rectangle tool, press the Up Arrow and Down 
Arrow keys while dragging to adjust the radius of rounded corners. 

- Oval and Rectangle tools: Shift-drag to constrain the shapes to circles and squares.

- Line tool: Shift-drag to constrain lines to multiples of 45° .

The Pen tool

To draw precise paths as straight lines or smooth, flowing curves, you can use the Pen tool. 
You can create straight or curved line segments and adjust the angle and length of straight 
segments and the slope of curved segments. 

When you draw with the Pen tool, you click to create points on straight line segments, and 
click and drag to create points on curved line segments. You can adjust straight and curved 
line segments by adjusting points on the line. You can convert curves to straight lines and 
the reverse. You can also display points on lines that you create with other Flash drawing 
tools, such as the Pencil, Brush, Line, Oval, or Rectangle tools, to adjust those lines.



Drawing curved paths with the Pen tool

You create curves by dragging the Pen tool in the direction you want the curve to go to create 
the first anchor point, and then dragging the Pen tool in the opposite direction to create the 
second anchor point.

When you use the Pen tool to create a curved segment, the anchor points of the line segment 
display tangent handles. The slope and length of each tangent handle determine the slope 
and the height, or depth, of the curve. Moving the tangent handles reshapes the curves of the 
path. See Adjusting segments.

To draw a curved path: 

1.  Select the Pen tool. 
2. Position the Pen tool on the Stage where you want the curve to begin, and hold down 
the mouse button. 

The first anchor point appears, and the pen tip changes to an arrowhead. 

3. Drag in the direction you want the curve segment to be drawn. Shift-drag to constrain 
the tool to multiples of 45° . 

As you drag, the tangent handles of the curve appear. 

4. Release the mouse button. 

The length and slope of the tangent handles determine the shape of the curve segment. 
You can move the tangent handles later to adjust the curve. 

5. Position the pointer where you want the curve segment to end, hold down the mouse 
button, and drag in the opposite direction to complete the segment. Shift-drag to constrain 
the segment to multiples of 45° . 

6. To draw the next segment of a curve, position the pointer where you want the next seg-
ment to end, and drag away from the curve.

Adjusting anchor points on paths

When you draw a curve with the Pen tool, you create curve points—anchor points on a con-
tinuous, curved path. When you draw a straight line segment, or a straight line connected to a 
curved segment, you create corner points—anchor points on a straight path or at the juncture 
of a straight and a curved path.



By default, selected curve points appear as hollow circles, and selected corner points appear 
as hollow squares.

To convert segments in a line from straight segments to curve segments or the reverse, you 
convert corner points to curve points or the reverse. 

You can also move, add, or delete anchor points on a path. You move anchor points using the 
Subselection tool to adjust the length or angle of straight segments or the slope of curved seg-
ments. You can nudge selected anchor points to make small adjustments. 

Deleting unneeded anchor points on a curved path optimizes the curve and reduces the file 
size.

To move an anchor point:

- Drag the point with the Subselection tool.

To nudge an anchor point or points:

- Select the point or points with the Subselection tool and use the arrow keys to move the 
point or points.

To convert an anchor point, do one of the following:

- To convert a corner point to a curve point, use the Subselection tool to select the point, 
then Alt-drag (Windows) or Option-drag (Macintosh) the point to place the tangent han-
dles.
- To convert a curve point to a corner point, click the point with the Pen tool.

To add an anchor point:

- Click a line segment with the Pen tool.



To delete an anchor point, do one of the following:

- To delete a corner point, click the point once with the Pen tool.
- To delete a curve point, click the point twice with the Pen tool. (Click once to convert the 
point to a corner point, and once more to delete the point.)
- Select the point with the Subselection tool and press Delete.

Reshaping using the Selection tool

To reshape a line or shape outline, you can drag any point on a line using the Selection tool. 
The pointer changes to indicate what type of reshaping it can perform on the line or fill.

Flash adjusts the curve of the line segment to accommodate the new position of the moved 
point. If the repositioned point is an end point, you can lengthen or shorten the line. If the 
repositioned point is a corner, the line segments forming the corner remain straight as they 
become longer or shorter.

When a corner appears next to the pointer, you can change an end point. When a curve ap-
pears next to the pointer, you can adjust a curve.

Some brush stroke areas are easier to reshape if you view them as outlines.

If you are having trouble reshaping a complex line, you can smooth it to remove some of its 
details, making reshaping easier. Increasing the magnification can also make reshaping easier 
and more accurate; see Optimizing curves or Using the Stage.

To reshape a line or shape outline using the Selection tool: 

1. Select the       Selection tool.
2. Do one of the following: 

- Drag from any point on the segment to reshape it. 
- Control-drag (Windows) or Option-drag (Macintosh) a line to create a new corner point.

Optimizing curves

Another way to smooth curves is to optimize them. This refines curved lines and fill outlines by 
reducing the number of curves used to define these elements. Optimizing curves also reduces 
the size of the Flash document (FLA file) and the exported Flash application (SWF file). As with 
the Smooth or Straighten modifiers or commands, you can apply optimization to the same ele-
ments multiple times.

To optimize curves:

1. Select the drawn elements to be optimized and select Modify > Optimize. 



To delete an anchor point, do one of the following:

- To delete a corner point, click the point once with the Pen tool.
- To delete a curve point, click the point twice with the Pen tool. (Click once to convert the 
point to a corner point, and once more to delete the point.)
- Select the point with the Subselection tool and press Delete.

About overlapping shapes in Flash

When you use the Pencil, Line, Oval, Rectangle, or Brush tool to draw a line across another 
line or painted shape, the overlapping lines are divided into segments at the intersection 
points. You can use the Selection tool to select, move, and reshape each segment individually.

A fill; the fill with a line drawn through it; and the two fills and three line segments created by 
segmentation

When you paint on top of shapes and lines, the portion underneath is replaced by whatever is 
on top. Paint of the same color merges together. Paint of different colors remains distinct. You 
can use these features to create masks, cutouts, and other negative images.

Erasing

Erasing with the Eraser tool removes strokes and fills. You can quickly erase everything on the 
Stage, erase individual stroke segments or filled areas, or erase by dragging. 

You can customize the Eraser tool to erase only strokes, only filled areas, or only a single filled 
area. The Eraser tool can be either round or square, and it can have one of five sizes. 

To quickly delete everything on the Stage:

-        Double-click the Eraser tool.

To remove stroke segments or filled areas:

1.         Select the Eraser tool, and then click the Faucet modifier. 
2. Click the stroke segment or filled area that you want to delete. 

To erase by dragging:

1.  Select the Eraser tool.
2.  Click the Eraser Mode modifier and select an erasing mode: 

- Erase Normal erases strokes and fills on the same layer.
- Erase Fills erases only fills; strokes are not affected.
- Erase Lines erases only strokes; fills are not affected.



- Erase Selected Fills erases only the currently selected fills and does not affect strokes, 
selected or not. (Select the fills you want to erase before using the Eraser tool in this 
mode.)
- Erase Inside erases only the fill on which you begin the eraser stroke. If you begin 
erasing from an empty point, nothing is erased. Strokes are unaffected by the eraser in 
this mode.

3. Click the Eraser Shape modifier and select an eraser shape and size. Make sure that the 
Faucet modifier is not selected.
4. Drag on the Stage.

Transforming objects freely

You can use the Free Transform tool to freely transform objects, groups, instances, or text 
blocks. You can perform individual transformations or combine several transformations, such 
as moving, rotating, scaling, skewing, and distortion.

To transform freely:

1. Select a graphic object, instance, group, or text block on the Stage.
2.      Click the Free Transform tool. 

Moving the pointer over and around the selection changes the pointer to indicate which 
transformation function is available.

3. Drag the handles to transform the selection, as follows: 

- To move the selection, position the pointer over the object within the bounding box, 
and drag the object to a new position. Do not drag the transformation point.
- To set the center of rotation or scaling, drag the transformation point to a new location.
- To rotate the selection, position the pointer just outside a corner handle and drag. The 
selection rotates around the transformation point. 

Shift-drag to rotate in 45° increments.

Alt-drag (Windows) or Option-drag (Macintosh) to rotate around the opposite corner.

- To scale the selection, drag a corner handle diagonally to scale in two dimensions. Drag 
a corner handle or a side handle horizontally or vertically to scale in the respective direc-
tion only. Shift-drag to resize proportionally. 
- To skew the selection, position the pointer on the outline between the transformation 
handles and drag. 
- To distort shapes, press Control (Windows) or Command (Macintosh) and drag a corner 
handle or a side handle. Shift-Control-drag (Windows) or Shift-Command-drag (Macin-
tosh) a corner handle to taper the object—to move the selected corner and the adjoining 
corner equal distances from their origins. For more information on distorting objects, see 
Distorting objects.

Note: The Free Transform tool cannot transform symbols, bitmaps, video objects, sounds, 
gradients, or text. If a multiple selection contains any of these, only the shape objects are 
distorted. To transform text, first convert the characters to shape objects.



4. To end the transformation, click outside the selected object, instance, or text block.

Scaling objects

Scaling an object enlarges or reduces the object horizontally, vertically, or both. You can scale 
an object by dragging or by entering values in the Transform panel. 

To scale objects by dragging:

1. Select a graphic object or objects on the Stage. 
2. Select Modify > Transform > Scale.
3. Do one of the following: 

- To scale the object both horizontally and vertically, drag one of the corner handles. 
Proportions are maintained as you scale. Shift-drag to scale nonuniformly.

- To scale the object either horizontally or vertically, drag a center handle.

4. To end the transformation, click outside the selected object or objects. 

Note: When you increase the size of a number of items, those near the edges of the 
bounding box might be moved off the Stage. If this occurs, select View > Work Area to see 
the elements that are beyond the edges of the Stage.

Add text

1. Select the Text tool from the toolbar and click on the Stage. 

      A text fi eld appears, with a round control that indicates that the fi eld will expand as you 
type. 

2. You can specify all the settings for the Text tool before you start typing. In the Property in-
spector, do the following: 
* Font text box. 
* IPoint Size text box.
* Text (fi ll) color box.

3. If necessary, click the Selection tool in the toolbar and move the text so that itʼs more cen-3. If necessary, click the 



tered under the car on the Stage.

Creating scrolling text

You can use the scroll and maxscroll properties of the TextField object to control vertical scroll-
ing and the hscroll and maxhscroll properties to control horizontal scrolling in a text block. The 
scroll and hscroll properties contain a number that specifies the topmost visible line in a text 
block; you can read and write these properties. The maxscroll and maxhscroll properties con-
tain a number that specifies the topmost visible line in a text block when the bottom line of 
the text is visible in the text block; you can only read these properties.

To use the scroll property to create scrolling text:

1. Assign an instance name to the text field that will contain scrolling text. Do one of the 
following: 

- Use the Text tool to create a text field on the Stage. Assign the text field an instance 
name in the Property inspector.
- Use ActionScript to create a text field dynamically with the createTextField method. As-
sign the text field an instance name as a parameter of the createTextField method.

2.  Create an Up button and a Down button or select Window > Other Panels > Com-
mon Libraries > Buttons and drag buttons to the Stage. You will use these buttons to 
scroll the text up and down.
3. Select the Up button on the Stage.
4.  In the Actions panel, select the Built-in Classes category, then select the Movie catego-
ry, then select the TextField category, and then select the Properties category. Finally, 
double-click the scroll property to add it to the Script pane.
5.  Replace instanceName with the instance name of the text field you want to scroll.
6.  Increment the scroll property by 1 to scroll the text up. The code should look like this: 

instName.scroll += 1;

7.  Select the Down button on the Stage.
8. Repeat steps 4 and 5.
9.  Decrement the scroll property by 1 to scroll the text down. The code should look like 
this: 

instName.scroll -= 1;

Aligning objects

The Align panel enables you to align selected objects along the horizontal or vertical axis. You 
can align objects vertically along the right edge, center, or left edge of the selected objects, 
or horizontally along the top edge, center, or bottom edge of the selected objects. Edges are 
determined by the bounding boxes enclosing each selected object.

Using the Align panel, you can distribute selected objects so that their centers or edges are 
evenly spaced. You can resize selected objects so that the horizontal or vertical dimensions of 
all objects match those of the largest selected object. You can also align selected objects to 
the Stage. You can apply one or more Align options to selected objects.



To align objects:

1. Select the objects to align.
2. Select Window > Design Panels > Align.
3. In the Align panel, select To Stage to apply alignment modifications relative to stage 
dimensions.
4. Select alignment buttons to modify the selected objects: 

- For Align, select Align Left, Align Horizontal Center, Align Right, Align Top, Align Vertical 
Center, or Align Bottom. 
- For Distribute, select Distribute Top, Distribute Horizontal Center, Distribute Bottom, 
Distribute Left, Distribute Vertical Center, or Distribute Right.
- For Match Size, select Match Width, Match Height, or Match Width and Height.
- For Space, select Space Horizontally or Space Vertically.

Tweened animation

Flash can create two types of tweened animation, motion tweening and shape tweening.

- In motion tweening, you define properties such as position, size, and rotation for an 
instance, group, or text block at one point in time, and then you change those properties 
at another point in time. You can also apply a motion tween along a path. See Tweening 
instances, groups, and type and Tweening motion along a path.
- In shape tweening, you draw a shape at one point in time, and then you change that 
shape or draw another shape at another point in time. Flash interpolates the values or 
shapes for the frames in between, creating the animation.

Tweened animation is an effective way to create movement and changes over time while mini-
mizing file size. In tweened animation, Flash stores only the values for the changes between 
frames.

To quickly prepare elements in a document for tweened animation, distribute objects to layers. 

You can apply tweened animation to an object on a mask layer to create a dynamic mask.

Frame-by-frame animation

Frame-by-frame animation changes the contents of the Stage in every frame and is best suit-
ed to complex animation in which an image changes in every frame instead of simply moving 
across the Stage. Frame-by-frame animation increases file size more rapidly than tweened 
animation. In frame-by-frame animation, Flash stores the values for each complete frame.

Layers in animation

Each scene in a Flash document can consist of any number of layers. As you animate, you use 
layers and layer folders to organize the components of an animation sequence and to separate 
animated objects so they don’t erase, connect, or segment each other. If you want Flash to 
tween the movement of more than one group or symbol at once, each must be on a separate 
layer. Typically, the background layer contains static artwork, and each additional layer con-
tains one separate animated object.

When a document has several layers, tracking and editing the objects on one or two of them 



can be difficult. This task is easier if you work with the contents of one layer at a time. Layer 
folders help you organize layers into manageable groups that you can expand and collapse to 
view only the layers relevant to your current task.

Creating keyframes

A keyframe is a frame where you define changes in the animation. When you create frame-
by-frame animation, every frame is a keyframe. In tweened animation, you define keyframes 
at significant points in the animation and let Flash create the contents of frames in between. 
Flash displays the interpolated frames of a tweened animation as light blue or light green 
with an arrow drawn between keyframes. Because Flash documents save the shapes in each 
keyframe, you should create keyframes only at those points in the artwork where something 
changes. 

Keyframes are indicated in the Timeline: a keyframe with content on it is represented by a 
solid circle, and an empty keyframe is represented by an empty circle before the frame. Sub-
sequent frames that you add to the same layer have the same content as the keyframe.

To create a keyframe, do one of the following:

- Select a frame in the Timeline and select Insert > Timeline > Keyframe.
- Right-click (Windows) or Control-click (Macintosh) a frame in the Timeline and select In-
sert Keyframe.

Representations of animations in the Timeline

Flash distinguishes tweened animation from frame-by-frame animation in the Timeline as fol-
lows:

- Motion tweens are indicated by a black dot at the beginning keyframe; intermediate 
tweened frames have a black arrow with a light blue background. 

- Shape tweens are indicated by a black dot at the beginning keyframe; intermediate 
frames have a black arrow with a light green background. 

- A dashed line indicates that the tween is broken or incomplete, such as when the final 
keyframe is missing. 

- A single keyframe is indicated by a black dot. Light gray frames after a single keyframe 
contain the same content with no changes and have a black line with a hollow rectangle at 
the last frame of the span. 



- A small a indicates that the frame has been assigned a frame action with the Actions 
panel. 

- A red flag indicates that the frame contains a label or comment. 

- A gold anchor indicates that the frame is a named anchor. 





Examples
Educational

http://www.wrc.wa.gov.au/schools/water_cycle.html
   Find out about water cycles in Western Australia.

http://science.howstuffworks.com/volcano3.htm
   How a Volcano Works

http://science.howstuffworks.com/engine3.htm
   How a Car Engine Works


